SCCM 2012 – Probleme beim wiederherstellen eines Backup

Während einer testweisen Sicherung und anschlißenden Wiederherstellung (LAB-UMGEBUNG) bekam ich bei dem „Prerequisite check“ zum „Recovery“ einen Fehler, sodass ich das Backup nicht einspielen konnte. Wohl gemerkt, der SCCM Server war frisch installiert und ich wollte die Wiederherstellungs-Funktion mit einem erfolgreichem Backup – einfach mal ausprobieren.

Szenario: Ein MP ist defekt und muss mit dem Backup, welches erfolgreich erstellt wurde, wieder hergestellt werden.

Damit der SCCM als „defekt“ erscheint habe ich folgendes gelöscht:
– Dateien aus dem LOG Verzeichnis
– Dateien aus dem INBOX Verzeichnis

Auch nachdem ich diese Datenbanken gelöscht hatte:

– Die SQL Datenbank der Site
– Die Reporting-Datanbank

lief der Check noch immer nicht durch und ich konnte mit dem Backup-Recovery nicht fortfahren !

Erst nachdem ich den kompletten Key:

  • [HKEY_LOCAL_MACHINE-SOFTWARE-Microsoft-SMSComponents-SMS_SITE_SQL_BACKUP

gelöscht hatte – konnte ich das Backup endlich wieder einspielen.

Ein zweiter Test bestätigte die Annahme. Um ein Backup wieder einspielen zu können muss der REG-Key _und_ die SQL Datenbank gelöscht werden ! Hilfreich war ein Eintrag auf diesem Blog: SuperchargedPC.com

Der SCCM Server war eine Version 2012 _ohne_ irgend ein Service Pack oder hotfix … Das Backup wurde schlussendlich wieder eingespielt, jedoch dauerte es eine Weile, biss der SCCM Server aus dem Read-Only Modus wieder umschaltete. Aber hierzu gab der SCCM auch eine Warnmeldung aus, wenn die SCCM Manager Konsole geöffnet wird.

… bis zum nächsten mal, Gunnar

%d Bloggern gefällt das: